Back to overview
Resolved

Frost Maintenance Window

Sep 17, 2026 at 11:00pm UTC  –  Sep 18, 2026 at 2:00am UTC
Affected services
portal.getfrost.io
api.getfrost.io/v1/health/liveness

Resolved
Sep 18, 2026 at 2:00am UTC

Maintenance ended

Created
Sep 17, 2026 at 11:00pm UTC

Recurring maintenance window for portal and systems upgrades.